Tropical Fruit Forum - International Tropical Fruit Growers



Author Topic: Forum Issue - All posts and messages from the 9th missing  (Read 445 times)

murahilin

  • Administrator
  • Hero Member
  • *****
  • Posts: 3235
    • USA Greenacres, Florida Zone 10b
    • View Profile
Forum Issue - All posts and messages from the 9th missing
« on: January 12, 2021, 08:49:51 AM »
A few forum members have messaged me regarding their posts and messages from the 9th being missing.

I was told that was caused by GoDaddy moving our hosting. The move took about a day, so everything that was posted after the move started was not transferred when the move was completed.

I don't think there was a way around that issue.

I just wanted to let everyone know about the issue so no one would think that we intentionally deleted their posts and messages from that day.

Plantinyum

  • Sr. Member
  • ****
  • Posts: 329
    • Bulgaria , near Sofia city , planting zone 7
    • View Profile
Re: Forum Issue - All posts and messages from the 9th missing
« Reply #1 on: January 12, 2021, 09:27:26 AM »
Thanks for clarifying this, I was wondering why I could not open any tread, an error message was occuring in every move I did .....

Kuhyay

  • Member
  • ***
  • Posts: 32
    • USA, CA, San Diego, 10a Sunset 24
    • View Profile
Re: Forum Issue - All posts and messages from the 9th missing
« Reply #2 on: January 12, 2021, 11:54:58 AM »
I noticed some other issues that were introduced recently.

Description:
When a user clicks an external link, such as from Google, the forum displays a 404 error.

Impact:
Users can not navigate to forum from search results.

Steps to reproduce:
  • Navigate to https://google.com
  • Search for "achachairu tropicalfruitforum" This can be any search that brings up individual posts
  • Click Link
  • Observe 404 error
Kenny

pj1881 (Patrick)

  • Administrator
  • Hero Member
  • *****
  • Posts: 1388
    • USA, Palm Beach, FL 33415, Zone 10a
    • View Profile
    • Brooks Tropical Nursery
Re: Forum Issue - All posts and messages from the 9th missing
« Reply #3 on: January 12, 2021, 02:59:29 PM »
It will take some time for Google to reindex the content of our site is what the hosting company is telling me.  We moved from a much older, slower, and smaller database version.  We had no choice, as the company and web in general are moving to the newer version.  This site is over 10 years old and delicate.  Sorry for any loss of data, there was no way to preserve everything without spending money.  We should be good for now, and Google will reindex us in time.

murahilin

  • Administrator
  • Hero Member
  • *****
  • Posts: 3235
    • USA Greenacres, Florida Zone 10b
    • View Profile
Re: Forum Issue - All posts and messages from the 9th missing
« Reply #4 on: January 12, 2021, 03:54:05 PM »
It will take some time for Google to reindex the content of our site is what the hosting company is telling me.  We moved from a much older, slower, and smaller database version.  We had no choice, as the company and web in general are moving to the newer version. This site is over 10 years old and delicate.  Sorry for any loss of data, there was no way to preserve everything without spending money.  We should be good for now, and Google will reindex us in time.

We are only 9 years old!

cbss_daviefl

  • Hero Member
  • *****
  • Posts: 1038
    • USA, Southwest Ranches,FL 33331, 10B
    • View Profile
    • bfgtropicals.com
Re: Forum Issue - All posts and messages from the 9th missing
« Reply #5 on: January 12, 2021, 04:46:17 PM »
Well 9 human years is like 01011010 software years. So the forum had a small bout of dementia. I am sure the posts selling $200 ultra rare 1 gallon plants will be back before you know it. ;)

It will take some time for Google to reindex the content of our site is what the hosting company is telling me.  We moved from a much older, slower, and smaller database version.  We had no choice, as the company and web in general are moving to the newer version. This site is over 10 years old and delicate.  Sorry for any loss of data, there was no way to preserve everything without spending money.  We should be good for now, and Google will reindex us in time.

We are only 9 years old!
Brandon

KonstiB

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: Forum Issue - All posts and messages from the 9th missing
« Reply #6 on: January 13, 2021, 10:50:55 AM »
I noticed some other issues that were introduced recently.

Description:
When a user clicks an external link, such as from Google, the forum displays a 404 error.

Impact:
Users can not navigate to forum from search results.

Steps to reproduce:
  • Navigate to https://google.com
  • Search for "achachairu tropicalfruitforum" This can be any search that brings up individual posts
  • Click Link
  • Observe 404 error


If you add http:// to the link it works :)

JakeFruit

  • Member
  • ***
  • Posts: 219
  • Gulf Coast of Florida
    • zone 10A
    • View Profile
Re: Forum Issue - All posts and messages from the 9th missing
« Reply #7 on: January 13, 2021, 11:46:04 AM »
The hosting company is blowing smoke without looking into your particular issue, but I doubt they'd be able to help you anyway. Indexing is not the problem, the problem Kuhyay is pointing out has been going on for quite awhile, I noticed the issue at least a year ago. It's Google Search-specific (doesn't replicate using Bing's search page). I do SEO and I've never seen this particular issue. Googling "achachairu tropicalfruitforum" and clicking on the link leads to the 404 page not found return, but if you copy the URL in the address bar (http://tropicalfruitforum.com/index.php?topic=11629.50) and paste it back directly into the address bar and click enter, the page loads! So, the exact same link works differently depending on how you access it. My guess is Google is injecting something into the request when a link is clicked that the SMF forum software doesn't like. Something weird is going on, I could probably figure it out with a few hours of digging, but I'm spread thin right now.

While I'm at it, you really need to put an SSL cert on this site and start serving it securely (https). With Let'sEncrypt, it's free and painless to implement. Sites still serving non-secure (http) content are penalized by Google in the SERPs (not that it's a big issue on your free site, but it's probably costing you new members). If your hosting provider doesn't offer the ability to add a Let'sEncrypt SSL cert for free, it shouldn't be more than a few dollars a year. If they are charging more than that, I would find a new hosting company....

Jani

  • Sr. Member
  • ****
  • Posts: 452
    • Miramar, FL
    • View Profile
Re: Forum Issue - All posts and messages from the 9th missing
« Reply #8 on: January 13, 2021, 12:53:37 PM »
Any reasons this can't be a secure site?
always longing for a JA Julie

 

Copyright © Tropical Fruit Forum - International Tropical Fruit Growers